fbpx

Forum

Alpha not working with x-plane 11  

  RSS
Otrman
(@otrman)
Active Member

I have tried 2 ways to use the yoke. 

First I connected the yoke to the latest version of x-plane, calibrated it.  My intention was to use two of the buttons to control the throttle function until the Bravo is available.  Started in the  air on approach to an airport.  Pitch and yaw controls worked perfectly, and by the way, great.  Using the standard button assignments for the yoke I could not make the hat switch respond nor could I re-assign any of the buttons.  The Logitech rudder system was used as well and worked just fine.

In a second test I connected both the alpha and saitek yoke system hoping to use the throttle portion throttle axis.  Again the alpha pitch and roll axis and  rudder worked fine.  I changed all the switches and axis except the throttle on the Saitek to None and all the buttons on the Saitek to "Do Nothing" on the Saitek to "Do Nothing" thinking there could there could be a conflict if both yokes were active. 

I was advised by Honeycomb that it would be OK to use the throttle portion of the Saitek while waiting  for the bravo.

I cannot use any of the switches on the Alpha.  Could there be some bug in the alpha that is causing this  or am I just doing something wrong.

Is there technical support from Honeycomb?  I have submitted this problem on the X-plane forum and the only suggestion was to undo all the alpha buttons and redo them manually.  That hasn't helped either.

Please help me.

Otrman

Quote
Posted : 04/11/2019 12:22 am
Honeycomb Aeronautical
(@honeycomb-aeronautical)
Member Admin

Hello Otrman,

Can you confirm that you have the yoke connector cable inserted? The ethernet coil cable included with the yoke connects to the base near the 5 starter ignition switch and the backside of the yoke handle. This creates the connection for all the buttons and rocker switches. The yoke is built with a solid steel shaft so for that reason, we use this connection method.

If you do have that plugged in, please detach and reinsert and see if you get a better connection.

If that solution does not work, please contact support@flyhoneycomb.com

ReplyQuote
Posted : 06/11/2019 5:21 am
dlmoRAGEgaming
(@dlmoragegaming)
Eminent Member

Couldn't be a case there isn't enough power for both yokes to be running off of your usb or some sort of conflict of having two yokes connected at once.

ReplyQuote
Posted : 07/11/2019 3:05 am
CrashLanding
(@crashlanding)
Active Member

My yoke is running on a MacBook Pro/Xplane 11 and originally wasn’t recognised properly, X-Plane “saw” the yoke but nothing could be calibrated or assigned.

The problem was the USB C converter I used so maybe worth checking your connections and experimenting in this area (my laptop only has USB C ports).

My Saitek yoke remains connected to the laptop to allow the Saitek throttle function as normal, its pitch and roll axes were changed to “ no function” to avoid clashing with the Alpha yoke and it all works smoothly. I also use Saitek rudders so our system setup is very similar.

ReplyQuote
Posted : 08/11/2019 11:05 am
PilotTe
(@pilotte)
New Member

Make sure, if you are still using your throttle connected to the Saitek Yoke, that your saitek yoke mappings have been removed so that they aren't over riding the Alpha settings.

ReplyQuote
Posted : 11/11/2019 7:49 pm
Share:

Please Login or Register